PDA

View Full Version : delete FACT


Raizel
22 March 2005, 01:51 AM
Before I knew where e-mail resided (Mailing Address), I created a FACT field named Email. I then moved _all_ to the designated location assigned to a person.

I can't delete the Fact. It says it's in use somewhere in the family but won't show me where. Index column Fact: Email shows every record empty. Yet it won't delete.

fjvanbodegom
22 March 2005, 12:29 PM
In fact you have two question.
First question: where is that specific fact (Email) in use (although there might be no content in the fields).
Options -> Define Person Fields -> second tab Facts. Activate the fact and click on the button Delete Fact. You get a message box that this fields in in use. Click on Search and you got a list of all the people whose record include this field.
Then you see alsoo a message: To remove all occuurences etc...

Second question: File -> Delete/Move Fields
Click in the upper part and choose the field you want to remove. Click on the Delete Field button. You got two warnings before the field and the content is completely removed.

Raizel
22 March 2005, 03:00 PM
In fact you have two question.
First question: where is that specific fact (Email) in use (although there might be no content in the fields).
Second question: File -> Delete/Move Fields
Frans van Bodegom
Dutch Reunion User Group

THANK YOU Frans! I was going about it from the wrong place and was hitting brick wall! There is no "find empty" (ah, another wish list item) so was at a loss. Just finished going through your steps and voila, all gone. All were indeed empty and if fact, not sure if I may have set for default when I first created it as the cards with the empty field don't have email (now in Address) nor do I even know the people.

fjvanbodegom
23 March 2005, 02:51 AM
Your wish exist in Reunion.
Find Anything (choose the field) ... is ... (leave the last field empty)

Raizel
23 March 2005, 11:22 PM
Your wish exist in Reunion.
Find Anything (choose the field) ... is ... (leave the last field empty)That didn't work. I had to do the steps mentioned in Frans response to finally get rid of the _empty_ field sitting in several records. there should be an option to find "empty" instead of all the steps it took to rid of the field. But, it's gone :)