PDA

View Full Version : Two part surnames


drlott
04 September 2006, 01:02 PM
When importing PAF 2.3 into Reunion 8, I found that the (two part) surnames Van Kirken, Van Arnsdalen, Van Ness and more have had an underline added between the Van and the second part of the name ( Van_Kirken). When using "find" (Van Kirken) is not recognized. there is no underline or dash in these names, just a space between the " Van" and the "Kirken, Arnsdalen" etc.

When I take out the underline, the surname is then alphabetized by the second part of the last name..i.e. Kirken, Ness, Arnsdalen etc.

How does one enter and keep the two part surname in Reunion 8?
I am now running into three part names i.e., Van der Vliet, Van der Hoff etc.
How can this be handled, then?
Diane Lott

theKiwi
04 September 2006, 02:31 PM
When importing PAF 2.3 into Reunion 8, I found that the (two part) surnames Van Kirken, Van Arnsdalen, Van Ness and more have had an underline added between the Van and the second part of the name ( Van_Kirken). When using "find" (Van Kirken) is not recognized. there is no underline or dash in these names, just a space between the " Van" and the "Kirken, Arnsdalen" etc.
Take a look inside the GEDCOM file. I think you'll find that PAF added the underscore as it did the Export.

Probably easiest way to fix this would be to edit the GEDCOM file before you import it into Reunion.

One way to to do this...

If you're SURE that the _ isn't used anywhere else in the PAF file, the open the GEDCOM file in a text editor like the free TextWrangler, and do a Find and replace - find all _ and replace them with a space. Then save the file.

When I take out the underline, the surname is then alphabetized by the second part of the last name..i.e. Kirken, Ness, Arnsdalen etc.

How does one enter and keep the two part surname in Reunion 8?
I am now running into three part names i.e., Van der Vliet, Van der Hoff etc.
How can this be handled, then?

You can control this in Reunion in the Options menu - choose "Indexing..." and set the option to Don't Sort on prefixes of less than x characters. If you set x to 4, then it will ignore van der as a prefix since each word is 3 characters.

Cheers

Roger

Karen Peters
04 September 2006, 07:04 PM
Thanks Roger,

The index was giving me problems with my Van Hoose ancestors, especially since some spelled it Van Hoose and some Vanhoose. I chose the "sort on entire last name" option and now everyone is in the index together.