PDA

View Full Version : Not linking to Photos


Mark Lazaroff
09 February 2018, 07:54 PM
I'm tying to add some photos of people in the tree. When I try to link to Photos the wheel just spins and never finds the library. I don't recall this problem with v11 only v12. Any idea what is wrong?

Dennis J. Cunniff
09 February 2018, 08:18 PM
I'm tying to add some photos of people in the tree. When I try to link to Photos the wheel just spins and never finds the library. I don't recall this problem with v11 only v12. Any idea what is wrong?

If your Photos library is not located inside your Pictures folder, you should add its path to your multimedia search folders.

Mark Lazaroff
10 February 2018, 07:35 AM
If your Photos library is not located inside your Pictures folder, you should add its path to your multimedia search folders.

I checked. It is located in the Pictures folder.

Dennis J. Cunniff
10 February 2018, 12:52 PM
I checked. It is located in the Pictures folder.

Sorry that didn't work. Someone else will have to guess.

Mark Lazaroff
10 February 2018, 01:24 PM
Sorry that didn't work. Someone else will have to guess.
What I wanted to do was hit the + and then find the photo in Photos to add the media to the person. It will not open Photos - it just spins.

What seems to work is to click on where the photo goes in Reunion and then drag and drop the photo from Photos. Reunion then stores the photo in ~Pictures/Reunion Pictures/Imported Media.

Half the the pics I had put in Reunion now only have thumbnails because the links are lost. Many of these were added from my Downloads folder, which is now empty. I thought that Reunion imported all media, but apparently it does not.

Dennis J. Cunniff
10 February 2018, 01:34 PM
What I wanted to do was hit the + and then find the photo in Photos to add the media to the person. It will not open Photos - it just spins.

What seems to work is to click on where the photo goes in Reunion and then drag and drop the photo from Photos. Reunion then stores the photo in ~Pictures/Reunion Pictures/Imported Media.

Half the the pics I had put in Reunion now only have thumbnails because the links are lost. Many of these were added from my Downloads folder, which is now empty. I thought that Reunion imported all media, but apparently it does not.

FWIW, the manual discourages the use of Photos and encourages you to keep media in a folder/file system of your own devising. (Look under "Working with Apple's Photos App"). You may find some other info there that would be useful.

You might also want to see what happens if you try to "Repair Multimedia Links" or "Rebuild Thumbnails".

Mark Lazaroff
10 February 2018, 02:26 PM
FWIW, the manual discourages the use of Photos and encourages you to keep media in a folder/file system of your own devising. (Look under "Working with Apple's Photos App"). You may find some other info there that would be useful.

You might also want to see what happens if you try to "Repair Multimedia Links" or "Rebuild Thumbnails".

First thanks for the help. I did try to repair the links - no luck. I think at least some of the problem was when Apple switched from iPhoto to Photos. Too risky having things tightly coupled to software systems that are always changing. I'll redo everything using drag and drop so that Reunion stores them locally.

Bob White
10 February 2018, 03:10 PM
Quote from the Help manual re: "Working with Apple's Photos App (and/or iPhoto):

If you're using the iPhoto app (not the newer Photos app), you can also add items from iPhoto via the Add button (+) in Reunion's Multimedia sidebar and Media window. After clicking the Add button, click Photos in the "Media" section of the Mac OS X Sidebar. (Note: Again, this does not work with the newer Photos app.)

Mark Lazaroff
10 February 2018, 03:30 PM
Quote from the Help manual re: "Working with Apple's Photos App (and/or iPhoto):

If you're using the iPhoto app (not the newer Photos app), you can also add items from iPhoto via the Add button (+) in Reunion's Multimedia sidebar and Media window. After clicking the Add button, click Photos in the "Media" section of the Mac OS X Sidebar. (Note: Again, this does not work with the newer Photos app.)

I'm using Photos (not iPhotos). But back when I added some of the pics, I was using iPhotos.